Back to overview
Degraded

DDoS

Apr 3, 2026 at 8:57pm UTC
Affected services
wtdawson.info
blog.wtdawson.info
weather.wtdawson.info

Resolved
Apr 4, 2026 at 4:17pm UTC

I believe the attack is over, I have unblocked traffic from outside the UK. I will continue to monitor, and block traffic again if the traffic rises back up again.

In total, it reached 556,804,621 requests, 378,178,611 of which were blocked. That means that approximately 67.91% of the requests were mitigated by Cloudflare DDoS protection, and my custom rules.
(These numbers are from 17:00~ 04/04/2026).

Updated
Apr 4, 2026 at 10:38am UTC

The website is still under active attack, now reaching nearly half a billion requests (average 20 million requests an hour)

Updated
Apr 3, 2026 at 9:38pm UTC

The website is still under attack.

All requests from outside the UK will be blocked until tomorrow

Updated
Apr 3, 2026 at 9:35pm UTC

The attack seems to have slowed, services are no longer degraded.

However, requests from outside the UK will still be challenged in the coming hours

Updated
Apr 3, 2026 at 9:22pm UTC

I believe the attack may have slowed slightly, so the block has been changed to an interactive challenge for countries outside the UK

Updated
Apr 3, 2026 at 9:12pm UTC

There have been nearly 2 Million requests being blocked by this new rule, which show that the attack is still active

Updated
Apr 3, 2026 at 9:05pm UTC

I believe it surpassed 150 Million requests, but appears to be at least slowing down due to the new blocking rule

Updated
Apr 3, 2026 at 9:00pm UTC

All countries except the UK have been blocked temporarily, it appears that it surpassed 100 Million requests, most blocked by Cloudflare

Created
Apr 3, 2026 at 8:57pm UTC

There is currently an ongoing DDoS attack against these websites